Wie aktiviere ich den ionCube Loader?

Um den ionCube Loader aktivieren zu können, müssen Sie eine eigene php.ini Datei anlegen. Am einfachsten können Sie diese Datei über das Modul Entwicklung über "Webserver Einstellungen hinzufügen" erstellen.

Nachdem Sie den Assistenten abgeschlossen haben, können Sie über "Aktion >" -> "Editor für php.ini Datei Starten" den php.ini-Editor starten.


Der ionCube Loader kann für PHP 7.0 wie folgt aktiviert werden:
;Zend
zend_extension = /usr/lib/php70/extensions/ioncube_loader_lin_7.0.so

Mit Thread Safety:
;Zend
zend_extension =/usr/lib/php70/extensions/ioncube_loader_lin_7.0_ts.so


Der ionCube Loader kann für PHP 7.1 wie folgt aktiviert werden:
;Zend
zend_extension = /usr/lib/php71/extensions/ioncube_loader_lin_7.1.so

Mit Thread Safety:
;Zend
zend_extension =/usr/lib/php71/extensions/ioncube_loader_lin_7.1_ts.so


Der ionCube Loader kann für PHP 7.2 wie folgt aktiviert werden:
;Zend
zend_extension = /usr/lib/php72/extensions/ioncube_loader_lin_7.2.so

Mit Thread Safety:
;Zend
zend_extension =/usr/lib/php72/extensions/ioncube_loader_lin_7.2_ts.so


Der ionCube Loader kann für PHP 7.3 wie folgt aktiviert werden:
;Zend
zend_extension = /usr/lib/php73/extensions/ioncube_loader_lin_7.3.so

Mit Thread Safety:
;Zend
zend_extension =/usr/lib/php73/extensions/ioncube_loader_lin_7.3_ts.so


Abschließend klicken Sie auf "Speichern", um die Änderungen zu übernehmen und den ionCube Loader zu aktivieren. Der ZendOptimizer ist generell nicht mehr verfügbar. Dieser ist seit PHP5.3 obsolet.